Design a site like this with WordPress.com
Get started

Parche público para VS para el problema de “Index was outside the bounds of the array”

Hace dos semanas escribí sobre algunas actualizaciones para algunos problemas al compilar ASP .NET 2.0. Podéis leerlo aquí.

En los comentarios de ese post mucha gente preguntaba sobre un problema que habían encontrado con el SP1 de Visual Studio cuando usan el comando “Publish Website” con un projecto web confiugardo para usar el servidor de desarrollo con una “/” como parte del directorio virtual (una técnica sobre la que ya escribí).

Específicamente, los que se han instalado el SP1 de Visual Studio 2005 han reportado que se han encontrado un error “Index was outside the bounds of the array” durante la publicación:

Desafortunadamente, este bug volvía a aparecer con el SP1 de VS 2005.

Las buenas noticias son que hemos publicado otro parche para este problema que os podéis descargar aquí. Omar Khan también a posteado sobre los detalles de este error y parcheado en el blog de MSDN WebDevTools (os recomiendo que os subscribáis).

Importante: La gente me pregunta muchas veces si deben instalar estos parches ántes de que observen el bug. Estos parches son para sistemas muy concretos, y no se le realizan pruebas a toda la linea de producto. Así, que sólo recomiendo que se lo instalen aquellos que hayan observado el error en su sistema.

Si tenéis problemas instalando el parche o si seguís con el error despues de instalarlo, contactad con el soporte de producto de Microsoft. Las llamadas al soporte de producto de Microsoft son gratuistas si están relacionadas con un bug de un producto. Podéis encontrar cómo contactar aquí.

Espero que sirva.

Scott.

Traducido por: Juan María Laó Ramos. Microsoft Student Partner

Author: Juanma

Bueno, como reza el título de este blog y de las cosas que iré escribiendo ya os hareis una idea de cómo soy.

One thought on “Parche público para VS para el problema de “Index was outside the bounds of the array””

  1. Si tienes el VS 2005 en español no te deja instalar el parche porque creo que es para la versión en ingles.

    Una vez te da ese error en un proyecto ¿ya no hay forma de dejarlo como antes, aunque vuelvas a poner la ruta de acceso virtual?

    Yo he estado intentandolo y no he podido. Debe quedarse algo mal internamente en ese proyecto en concreto.

    Saludos.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: